What’s Vulnerable › Vulnerabilities
CVE-2024-32838: Apache Fineract: SQL injection vulnerabilities in offices API endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL Injection vulnerability in various API endpoints - offices, dashboards, etc. Apache Fineract versions 1.9 and before have a vulnerability that allows an authenticated attacker to inject malicious data into some of the REST API endpoints' query parameter. Users are recommended to upgrade to version 1.10.1, which fixes this issue. A SQL Validator has been implemented which allows us to configure a series of tests and checks against our SQL queries that will allow us to validate and protect against nearly all potential SQL injection attacks.
Affected products
- Apache Software Foundation Apache Fineract: from 1.4.0 before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fineract 1.10.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/7l88h17pn9nf8zpx5bbojk7ko5oxo1dy
- http://www.openwall.com/lists/oss-security/2025/02/12/1
Get alerted when CVE-2024-32838 or the next vulnerability affects your stack