What’s Vulnerable › Vulnerabilities
CVE-2024-32855
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-787
Description
Dell Client Platform BIOS contains an Out-of-bounds Write vulnerability in an externally developed component. A high privileged attacker with local access could potentially exploit this vulnerability, leading to Information tampering.
Affected products
- Dell Inspiron 3480 Firmware: before 1.30.0 — fixed in 1.30.0
- Dell Inspiron 3580 Firmware: before 1.30.0 — fixed in 1.30.0
- Dell Latitude 3120 Firmware: before 1.26.0 — fixed in 1.26.0
- Dell Latitude 3190 2-In-1 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 3190 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 3300 Firmware: before 1.28.0 — fixed in 1.28.0
- Dell Latitude 3310 2-In-1 Firmware: before 1.24.0 — fixed in 1.24.0
- Dell Latitude 3310 Firmware: before 1.25.0 — fixed in 1.25.0
- Dell Latitude 3390 2-In-1 Firmware: before 1.31.0 — fixed in 1.31.0
- Dell Latitude 5288 Firmware: before 1.36.0 — fixed in 1.36.0
- Dell Latitude 5290 2-In-1 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 5290 Firmware: before 1.35.0 — fixed in 1.35.0
- Dell Latitude 5300 2-In-1 Firmware: before 1.31.0 — fixed in 1.31.0
- Dell Latitude 5300 Firmware: before 1.31.0 — fixed in 1.31.0
- Dell Latitude 5310 2-In-1 Firmware: before 1.24.0 — fixed in 1.24.0
- Dell Latitude 5310 Firmware: before 1.24.0 — fixed in 1.24.0
- Dell Latitude 5400 Firmware: before 1.30.0 — fixed in 1.30.0
- Dell Latitude 5401 Firmware: before 1.31.0 — fixed in 1.31.0
- Dell Latitude 5410 Firmware: before 1.28.0 — fixed in 1.28.0
- Dell Latitude 5411 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 5420 Rugged Firmware: before 1.32.0 — fixed in 1.32.0
- Dell Latitude 5424 Rugged Firmware: before 1.32.0 — fixed in 1.32.0
- Dell Latitude 5480 Firmware: before 1.36.0 — fixed in 1.36.0
- Dell Latitude 5488 Firmware: before 1.36.0 — fixed in 1.36.0
- Dell Latitude 5490 Firmware: before 1.35.0 — fixed in 1.35.0
- Dell Latitude 5491 Firmware: before 1.33.0 — fixed in 1.33.0
- Dell Latitude 5500 Firmware: before 1.30.0 — fixed in 1.30.0
- Dell Latitude 5501 Firmware: before 1.31.0 — fixed in 1.31.0
- Dell Latitude 5510 Firmware: before 1.28.0 — fixed in 1.28.0
- Dell Latitude 5511 Firmware: before 1.29.0 — fixed in 1.29.0
How to fix
Upgrade to a fixed version: Dell Inspiron 3480 Firmware 1.30.0; Dell Inspiron 3580 Firmware 1.30.0; Dell Latitude 3120 Firmware 1.26.0; Dell Latitude 3190 2-In-1 Firmware 1.34.0; Dell Latitude 3190 Firmware 1.34.0; Dell Latitude 3300 Firmware 1.28.0; Dell Latitude 3310 2-In-1 Firmware 1.24.0; Dell Latitude 3310 Firmware 1.25.0; Dell Latitude 3390 2-In-1 Firmware 1.31.0; Dell Latitude 5288 Firmware 1.36.0; Dell Latitude 5290 2-In-1 Firmware 1.34.0; Dell Latitude 5290 Firmware 1.35.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000225627/dsa-2024-123
- https://www.dell.com/support/kbdoc/en-us/000225627/dsa-2024-123
Get alerted when CVE-2024-32855 or the next vulnerability affects your stack