What’s Vulnerable › Vulnerabilities
CVE-2024-3291: Privilege Escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-281
Description
When installing Nessus Agent to a directory outside of the default location on a Windows host, Nessus Agent versions prior to 10.6.4 did not enforce secure permissions for sub-directories. This could allow for local privilege escalation if users had not secured the directories in the non-default installation location.
Affected products
- Tenable Agent: before 10.6.4 — fixed in 10.6.4
How to fix
Upgrade to a fixed version: Tenable Agent 10.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-3291 or the next vulnerability affects your stack