What’s Vulnerable › Vulnerabilities
CVE-2024-32945: LaTeX post content manipulation via renderer state leak across contexts
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-15 · updated 2026-06-17
- Weakness: CWE-909
Description
Mattermost Mobile Apps versions <=2.16.0 fail to protect against abuse of a globally shared MathJax state which allows an attacker to change the contents of a LateX post, by creating another post with specific macro definitions.
Affected products
- Mattermost Mobile: before 2.17.0 — fixed in 2.17.0
How to fix
Upgrade to a fixed version: Mattermost Mobile 2.17.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-32945 or the next vulnerability affects your stack