What’s Vulnerable › Vulnerabilities
CVE-2024-32959: WordPress Sirv plugin <= 7.2.2 - Arbitrary Option Update to Privilege Escalation vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-266
Description
Incorrect Privilege Assignment vulnerability in Sirv CDN and Image Hosting Sirv sirv.This issue affects Sirv: from n/a through <= 7.2.2.
Affected products
- sirv Image Optimizer, Resizer and CDN – Sirv: before 7.2.3 — fixed in 7.2.3
How to fix
Upgrade to a fixed version: sirv Image Optimizer, Resizer and CDN – Sirv 7.2.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/sirv/vulnerability/wordpress-sirv-plugin-7-2-2-arbitrary-option-update-to-privilege-escalation-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/sirv/wordpress-sirv-plugin-7-2-2-arbitrary-option-update-to-privilege-escalation-vulnerability?_s_id=cve
Get alerted when CVE-2024-32959 or the next vulnerability affects your stack