What’s Vulnerable › Vulnerabilities
CVE-2024-32961: WordPress Blocksy theme <= 2.0.33 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in creativethemeshq Blocksy blocksy.This issue affects Blocksy: from n/a through <= 2.0.33.
Affected products
- creativethemeshq Blocksy: before 2.0.34 — fixed in 2.0.34
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy 2.0.34. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Theme/blocksy/vulnerability/wordpress-blocksy-theme-2-0-33-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/blocksy/wordpress-blocksy-theme-2-0-33-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-32961 or the next vulnerability affects your stack