What’s Vulnerable › Vulnerabilities
CVE-2024-32965: ssrf vulnerability in lobe-chat
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 26.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-918
Description
Lobe Chat is an open-source, AI chat framework. Versions of lobe-chat prior to 1.19.13 have an unauthorized ssrf vulnerability. An attacker can construct malicious requests to cause SSRF without logging in, attack intranet services, and leak sensitive information. The jwt token header X-Lobe-Chat-Auth strored proxy address and OpenAI API Key, can be modified to scan an internal network in the target lobe-web environment. This issue has been addressed in release version 1.19.13 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- lobehub lobe-chat: before 1.19.13 — fixed in 1.19.13
How to fix
Upgrade to a fixed version: lobehub lobe-chat 1.19.13. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobe-chat/commit/e960a23b0c69a5762eb27d776d33dac443058faf
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-2xcc-vm3f-m8rw
Get alerted when CVE-2024-32965 or the next vulnerability affects your stack