What’s Vulnerable › Vulnerabilities
CVE-2024-32972: go-ethereum denial of service via malicious p2p message
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-06 · updated 2026-06-17
- Weakness: CWE-400
Description
go-ethereum (geth) is a golang execution layer implementation of the Ethereum protocol. Prior to 1.13.15, a vulnerable node can be made to consume very large amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix has been included in geth version `1.13.15` and onwards.
Affected products
- ethereum go-ethereum: before 1.13.15 — fixed in 1.13.15
How to fix
Upgrade to a fixed version: ethereum go-ethereum 1.13.15. Check the vendor advisory for mitigations.
References
- https://github.com/ethereum/go-ethereum/compare/v1.13.14...v1.13.15
- https://github.com/ethereum/go-ethereum/security/advisories/GHSA-4xc9-8hmq-j652
- https://github.com/ethereum/go-ethereum/compare/v1.13.14...v1.13.15
- https://github.com/ethereum/go-ethereum/security/advisories/GHSA-4xc9-8hmq-j652
Get alerted when CVE-2024-32972 or the next vulnerability affects your stack