What’s Vulnerable › Vulnerabilities
CVE-2024-32973: Remote for TLS session may be trusted despite constraints in Pluto lang
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-06-17
- Weakness: CWE-284
Description
Pluto is a superset of Lua 5.4 with a focus on general-purpose programming. In affected versions an attacker with the ability to actively intercept network traffic would be able to use a specifically-crafted certificate to fool Pluto into trusting it to be the intended remote for the TLS session. This results in the HTTP library and socket.starttls providing less transport integrity than expected. This issue has been patched in pull request #851 which has been included in version 0.9.3. Users are advised to upgrade. there are no known workarounds for this vulnerability.
Affected products
- PlutoLang Pluto: from 0.9.0 before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: PlutoLang Pluto 0.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/PlutoLang/Pluto/pull/851
- https://github.com/PlutoLang/Pluto/security/advisories/GHSA-84hj-7j2v-w665
- https://github.com/PlutoLang/Pluto/pull/851
- https://github.com/PlutoLang/Pluto/security/advisories/GHSA-84hj-7j2v-w665
Get alerted when CVE-2024-32973 or the next vulnerability affects your stack