What’s Vulnerable › Vulnerabilities

CVE-2024-3303: Improper Neutralization of Input Used for LLM Prompting in GitLab

Description

An issue was discovered in GitLab EE affecting all versions starting from 16.0 prior to 17.6.5, starting from 17.7 prior to 17.7.4, and starting from 17.8 prior to 17.8.2, which allows an attacker to exfiltrate contents of a private issue using prompt injection.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.6.5, 17.7.4, 17.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-3303 or the next vulnerability affects your stack