What’s Vulnerable › Vulnerabilities
CVE-2024-3340: Colibri Page Builder <= 1.0.272 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'colibri-gallery-slideshow' Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Colibri Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'colibri-gallery-slideshow' shortcode in all versions up to, and including, 1.0.272 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- extendthemes Colibri Page Builder: before 1.0.274 — fixed in 1.0.274
How to fix
Upgrade to a fixed version: extendthemes Colibri Page Builder 1.0.274. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3074785/colibri-page-builder/trunk/extend-builder/shortcodes/index.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f5ba832e-98bc-421d-9b60-e6260c408815?source=cve
- https://plugins.trac.wordpress.org/changeset/3074785/colibri-page-builder/trunk/extend-builder/shortcodes/index.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f5ba832e-98bc-421d-9b60-e6260c408815?source=cve
Get alerted when CVE-2024-3340 or the next vulnerability affects your stack