What’s Vulnerable › Vulnerabilities
CVE-2024-3344: Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE <= 2.6.8 - Authenticated (Author+) Limited File Upload to Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-434
Description
The Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file upload in all versions up to, and including, 2.6.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE: before 2.6.9 — fixed in 2.6.9
How to fix
Upgrade to a fixed version: themeisle Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE 2.6.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3068495/otter-blocks
- https://www.wordfence.com/threat-intel/vulnerabilities/id/db836f4b-d31f-4442-89a5-1a400525c598?source=cve
- https://plugins.trac.wordpress.org/changeset/3068495/otter-blocks
- https://www.wordfence.com/threat-intel/vulnerabilities/id/db836f4b-d31f-4442-89a5-1a400525c598?source=cve
Get alerted when CVE-2024-3344 or the next vulnerability affects your stack