What’s Vulnerable › Vulnerabilities
CVE-2024-3345: ShopLentor <= 2.8.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via woolentorsearch Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The ShopLentor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's woolentorsearch shortcode in all versions up to, and including, 2.8.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin 2.8.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/2.8.3/includes/modules/ajax-search/base.php#L137
- https://plugins.trac.wordpress.org/changeset/3088881/woolentor-addons/trunk/includes/modules/ajax-search/base.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d6a73a7f-53ac-4930-a1cd-c39818f64678?source=cve
- https://plugins.trac.wordpress.org/browser/woolentor-addons/tags/2.8.3/includes/modules/ajax-search/base.php#L137
- https://plugins.trac.wordpress.org/changeset/3088881/woolentor-addons/trunk/includes/modules/ajax-search/base.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d6a73a7f-53ac-4930-a1cd-c39818f64678?source=cve
Get alerted when CVE-2024-3345 or the next vulnerability affects your stack