What’s Vulnerable › Vulnerabilities

CVE-2024-33504

Description

A use of hard-coded cryptographic key to encrypt sensitive data vulnerability [CWE-321] in FortiManager 7.6.0 through 7.6.1, 7.4.0 through 7.4.5, 7.2.0 through 7.2.9, 7.0 all versions, 6.4 all versions may allow an attacker with JSON API access permissions to decrypt some secrets even if the 'private-data-encryption' setting is enabled.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiManager 7.2.10, 7.4.6, 7.6.2; Fortinet FortiManager Cloud 7.2.9, 7.4.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-33504 or the next vulnerability affects your stack