What’s Vulnerable › Vulnerabilities
CVE-2024-33511
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-06-17
- Weakness: CWE-121
Description
There is a buffer overflow vulnerability in the underlying Automatic Reporting service that could lead to unauthenticated remote code execution by sending specially crafted packets destined to the PAPI (Aruba's access point management protocol) UDP port (8211). Successful exploitation of this vulnerability results in the ability to execute arbitrary code as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 8.10.0.0 before 8.10.0.10; from 10.5.0.0 before 10.5.1.0; from 10.4.0.0 before 10.4.1.0; from 8.11.0.0 before 8.11.2.1; from 10.3.0.0 before 10.4.0.0; from 8.9.0.0 before 8.10.0.0 — fixed in 10.4.0.0, 10.4.1.0, 10.5.1.0, 6.5.5.0, 8.10.0.0, 8.10.0.10
- Arubanetworks Sd-Wan: from 8.7.0.0; from 8.6.0.4
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.0.0, 10.4.1.0, 10.5.1.0, 6.5.5.0. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-004.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2024-004.txt
Get alerted when CVE-2024-33511 or the next vulnerability affects your stack