What’s Vulnerable › Vulnerabilities

CVE-2024-33522: Privilege escalation in Calico CNI install binary

Description

In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0 and below), an attacker who has local access to the Kubernetes node, can escalate their privileges by exploiting a vulnerability in the Calico CNI install binary. The issue arises from an incorrect SUID (Set User ID) bit configuration in the binary, combined with the ability to control the input binary, allowing an attacker to execute an arbitrary binary with elevated privileges.

Affected products

How to fix

Upgrade to a fixed version: Tigera Calico v3.26.5, v3.27.3; Tigera Calico Cloud v19.3.0; Tigera Calico Enterprise v3.17.4, v3.18.2, v3.19.0-2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-33522 or the next vulnerability affects your stack