What’s Vulnerable › Vulnerabilities
CVE-2024-33528
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
A Stored Cross-site Scripting (XSS) vulnerability in ILIAS 7 before 7.30 and ILIAS 8 before 8.11 allows remote authenticated attackers with tutor privileges to inject arbitrary web script or HTML via XML file upload.
Affected products
- ILIAS: from 7.0 before 7.30; from 8.0 before 8.11 — fixed in 7.30, 8.11
How to fix
Upgrade to a fixed version: ILIAS 7.30, 8.11. Check the vendor advisory for mitigations.
References
- https://docu.ilias.de/ilias.php?baseClass=illmpresentationgui&cmd=layout&ref_id=1719&obj_id=170029
- https://insinuator.net/2024/05/security-advisory-achieving-php-code-execution-in-ilias-elearning-lms-before-v7-30-v8-11-v9-1/
- https://docu.ilias.de/ilias.php?baseClass=illmpresentationgui&cmd=layout&ref_id=1719&obj_id=170029
- https://insinuator.net/2024/05/security-advisory-achieving-php-code-execution-in-ilias-elearning-lms-before-v7-30-v8-11-v9-1/
Get alerted when CVE-2024-33528 or the next vulnerability affects your stack