What’s Vulnerable › Vulnerabilities
CVE-2024-33537: WordPress WP Portfolio theme <= 2.4 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Theme Horse WP Portfolio allows Stored XSS.This issue affects WP Portfolio: from n/a through 2.4.
Affected products
- Theme Horse WP Portfolio: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: Theme Horse WP Portfolio 2.5. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-portfolio/wordpress-wp-portfolio-theme-2-4-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-portfolio/wordpress-wp-portfolio-theme-2-4-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-33537 or the next vulnerability affects your stack