What’s Vulnerable › Vulnerabilities
CVE-2024-3371: Insufficient validation of external input in Compass may enable MITM attacks
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-24 · updated 2026-06-17
- Weakness: CWE-360
Description
MongoDB Compass may accept and use insufficiently validated input from an untrusted external source. This may cause unintended application behavior, including data disclosure and enabling attackers to impersonate users. This issue affects MongoDB Compass versions 1.35.0 to 1.42.0.
Affected products
- MongoDB Compass: from 1.35.0 before 1.42.1 — fixed in 1.42.1
How to fix
Upgrade to a fixed version: MongoDB Compass 1.42.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-3371 or the next vulnerability affects your stack