What’s Vulnerable › Vulnerabilities
CVE-2024-3372: MongoDB Server may have unexpected application behaviour due to invalid BSON
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper validation of certain metadata input may result in the server not correctly serialising BSON. This can be performed pre-authentication and may cause unexpected application behavior including unavailability of serverStatus responses. This issue affects MongoDB Server v7.0 versions prior to 7.0.6, MongoDB Server v6.0 versions prior to 6.0.14 and MongoDB Server v.5.0 versions prior to 5.0.25.
Affected products
- MongoDB: from 5.0.0 before 5.0.25; from 6.0.0 before 6.0.14; from 7.0.0 before 7.0.6 — fixed in 5.0.25, 6.0.14, 7.0.6
How to fix
Upgrade to a fixed version: MongoDB 5.0.25, 6.0.14, 7.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-3372 or the next vulnerability affects your stack