What’s Vulnerable › Vulnerabilities
CVE-2024-3379: Incorrect Authorization in lunary-ai/lunary
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-863
Description
In lunary-ai/lunary versions 1.2.2 through 1.2.6, an incorrect authorization vulnerability allows unprivileged users to re-generate the private key for projects they do not have access to. Specifically, a user with a 'Member' role can issue a request to regenerate the private key of a project without having the necessary permissions or being assigned to that project. This issue was fixed in version 1.2.7.
Affected products
- lunary-ai/lunary: from 1.2.2 before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/c57cd50fa0477fd2a2efe60810c0099eebd66f54
- https://huntr.com/bounties/739df024-a112-47aa-b51d-988c3f855e92
Get alerted when CVE-2024-3379 or the next vulnerability affects your stack