What’s Vulnerable › Vulnerabilities
CVE-2024-3386: PAN-OS: Predefined Decryption Exclusions Does Not Work as Intended
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-436
Description
An incorrect string comparison vulnerability in Palo Alto Networks PAN-OS software prevents Predefined Decryption Exclusions from functioning as intended. This can cause traffic destined for domains that are not specified in Predefined Decryption Exclusions to be unintentionally excluded from decryption.
Affected products
- Palo Alto Networks PAN-OS: from 9.0.0 before 9.0.16; from 9.1.0 before 9.1.17; from 10.0.0 before 10.0.13; from 10.1.0 through 10.1.8; from 10.2.0 before 10.2.4; from 11.0.0 before 11.0.1 — fixed in 9.0.16, 9.1.17, 10.0.13, 10.2.4, 11.0.1
- Palo Alto Networks PAN-OS: from 9.0.0 before 9.0.17-h2; from 9.1.0 before 9.1.17; from 10.0.0 before 10.0.13; from 10.1.0 before 10.1.9-h3; from 10.1.0 before 10.1.10; from 10.2.0 before 10.2.4-h2 — fixed in 9.0.17-h2, 9.1.17, 10.0.13, 10.1.9-h3, 10.1.10, 10.2.4-h2
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 9.0.16, 9.1.17, 10.0.13, 10.2.4; Palo Alto Networks PAN-OS 9.0.17-h2, 9.1.17, 10.0.13, 10.1.9-h3. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2024-3386
- https://security.paloaltonetworks.com/CVE-2024-3386
Get alerted when CVE-2024-3386 or the next vulnerability affects your stack