What’s Vulnerable › Vulnerabilities
CVE-2024-3387: PAN-OS: Weak Certificate Strength in Panorama Software Leads to Sensitive Information Disclosure
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-326
Description
A weak (low bit strength) device certificate in Palo Alto Networks Panorama software enables an attacker to perform a meddler-in-the-middle (MitM) attack to capture encrypted traffic between the Panorama management server and the firewalls it manages. With sufficient computing resources, the attacker could break encrypted communication and expose sensitive information that is shared between the management server and the firewalls.
Affected products
- Palo Alto Networks PAN-OS: from 10.1.0 before 10.1.12; from 10.2.0 before 10.2.7; from 11.0.0 before 11.0.4; 10.2.7-h1, 10.2.7-h2, 10.2.7-h3, 10.2.7-h4, 10.2.7-h5, 10.2.7-h6 — fixed in 10.1.12, 10.2.7, 11.0.4
- Palo Alto Networks PAN-OS: 10.2.2
- Palo Alto Networks PAN-OS: from 10.1.0 before 10.1.12; from 10.2.0 before 10.2.7-h3; from 10.2.0 before 10.2.8; from 11.0.0 before 11.0.4 — fixed in 10.1.12, 10.2.7-h3, 10.2.8, 11.0.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.12, 10.2.7, 11.0.4; Palo Alto Networks PAN-OS 10.1.12, 10.2.7-h3, 10.2.8, 11.0.4. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2024-3387
- https://security.paloaltonetworks.com/CVE-2024-3387
Get alerted when CVE-2024-3387 or the next vulnerability affects your stack