What’s Vulnerable › Vulnerabilities
CVE-2024-33921: WordPress ReviewX plugin <= 1.6.21 - Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-281
Description
Broken Access Control vulnerability in ReviewX.This issue affects ReviewX: from n/a through 1.6.21.
Affected products
- ReviewX – Multi-Criteria Reviews for WooCommerce with Google Reviews & Schema: before 1.6.22 — fixed in 1.6.22
How to fix
Upgrade to a fixed version: ReviewX – Multi-Criteria Reviews for WooCommerce with Google Reviews & Schema 1.6.22. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/reviewx/wordpress-reviewx-plugin-1-6-21-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/reviewx/wordpress-reviewx-plugin-1-6-21-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2024-33921 or the next vulnerability affects your stack