What’s Vulnerable › Vulnerabilities
CVE-2024-33933: WordPress Elementor Header & Footer Builder plugin <= 1.6.35 - Contributor+ DOM-Based Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template allows DOM-Based XSS.This issue affects Elementor – Header, Footer & Blocks Template: from n/a through 1.6.35.
Affected products
- Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template: before 1.6.36 — fixed in 1.6.36
How to fix
Upgrade to a fixed version: Brainstorm Force, Nikhil Chavan Elementor – Header, Footer & Blocks Template 1.6.36. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/header-footer-elementor/wordpress-elementor-header-footer-builder-plugin-1-6-35-contributor-dom-based-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/header-footer-elementor/wordpress-elementor-header-footer-builder-plugin-1-6-35-contributor-dom-based-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-33933 or the next vulnerability affects your stack