What’s Vulnerable › Vulnerabilities
CVE-2024-33996: moodle: broken access control when setting calendar event type
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-20
Description
Incorrect validation of allowed event types in a calendar web service made it possible for some users to create events with types/audiences they did not have permission to publish to.
Affected products
- Moodle: before 4.1.10; from 4.2.0 before 4.2.7; from 4.3.0 before 4.3.4 — fixed in 4.1.10, 4.2.7, 4.3.4
How to fix
Upgrade to a fixed version: Moodle 4.1.10, 4.2.7, 4.3.4. Check the vendor advisory for mitigations.
References
- https://moodle.org/mod/forum/discuss.php?d=458384#p1840909
- https://moodle.org/mod/forum/discuss.php?d=458384#p1840909
Get alerted when CVE-2024-33996 or the next vulnerability affects your stack