What’s Vulnerable › Vulnerabilities
CVE-2024-33999: moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-20
Description
The referrer URL used by MFA required additional sanitizing, rather than being used directly.
Affected products
- Moodle: from 4.3.0 before 4.3.4 — fixed in 4.3.4
How to fix
Upgrade to a fixed version: Moodle 4.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-33999 or the next vulnerability affects your stack