What’s Vulnerable › Vulnerabilities
CVE-2024-34005: moodle: authenticated LFI risk in some misconfigured shared hosting environments via modified mod_data backup
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-200
Description
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore database activity modules and direct access to the web server outside of the Moodle webroot could execute a local file include.
Affected products
- Moodle: before 4.1.10; from 4.2.0 before 4.2.7; from 4.3.0 before 4.3.4 — fixed in 4.1.10, 4.2.7, 4.3.4
How to fix
Upgrade to a fixed version: Moodle 4.1.10, 4.2.7, 4.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34005 or the next vulnerability affects your stack