What’s Vulnerable › Vulnerabilities
CVE-2024-34007: moodle: logout CSRF in admin/tool/mfa/auth.php
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-352
Description
The logout option within MFA did not include the necessary token to avoid the risk of users inadvertently being logged out via CSRF.
Affected products
- Moodle: from 4.3.0 before 4.3.4 — fixed in 4.3.4
How to fix
Upgrade to a fixed version: Moodle 4.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34007 or the next vulnerability affects your stack