What’s Vulnerable › Vulnerabilities
CVE-2024-34008: moodle: CSRF risk in analytics management of models
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-31 · updated 2026-06-17
- Weakness: CWE-352
Description
Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.
Affected products
- Moodle: from 4.0 before 4.3.4; from 4.1 before 4.1.10; from 4.2 before 4.2.7 — fixed in 4.1.10, 4.2.7, 4.3.4
How to fix
Upgrade to a fixed version: Moodle 4.1.10, 4.2.7, 4.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34008 or the next vulnerability affects your stack