What’s Vulnerable › Vulnerabilities
CVE-2024-34027: f2fs: compress: fix to cover {reserve,release}_compress_blocks() w/ cp_rwsem lock
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-24 · updated 2026-10-15
- Weakness: CWE-770
Description
In the Linux kernel, the following vulnerability has been resolved: f2fs: compress: fix to cover {reserve,release}_compress_blocks() w/ cp_rwsem lock It needs to cover {reserve,release}_compress_blocks() w/ cp_rwsem lock to avoid racing with checkpoint, otherwise, filesystem metadata including blkaddr in dnode, inode fields and .total_valid_block_count may be corrupted after SPO case.
Affected products
- Linux kernel: from 5.8 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33; from 6.7 before 6.9.4 — fixed in 5.10.219, 5.15.161, 6.1.93, 6.6.33, 6.9.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.219, 5.15.161, 6.1.93, 6.6.33. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0a4ed2d97cb6d044196cc3e726b6699222b41019
- https://git.kernel.org/stable/c/329edb7c9e3b6ca27e6ca67ab1cdda1740fb3a2b
- https://git.kernel.org/stable/c/5d47d63883735718825ca2efc4fca6915469774f
- https://git.kernel.org/stable/c/69136304fd144144a4828c7b7b149d0f80321ba4
- https://git.kernel.org/stable/c/a6e1f7744e9b84f86a629a76024bba8468aa153b
- https://git.kernel.org/stable/c/b5bac43875aa27ec032dbbb86173baae6dce6182
- https://git.kernel.org/stable/c/0a4ed2d97cb6d044196cc3e726b6699222b41019
- https://git.kernel.org/stable/c/329edb7c9e3b6ca27e6ca67ab1cdda1740fb3a2b
- https://git.kernel.org/stable/c/5d47d63883735718825ca2efc4fca6915469774f
- https://git.kernel.org/stable/c/69136304fd144144a4828c7b7b149d0f80321ba4
- https://git.kernel.org/stable/c/a6e1f7744e9b84f86a629a76024bba8468aa153b
- https://git.kernel.org/stable/c/b5bac43875aa27ec032dbbb86173baae6dce6182
Get alerted when CVE-2024-34027 or the next vulnerability affects your stack