What’s Vulnerable › Vulnerabilities

CVE-2024-34029: AD/LDAP Group Members Leak

Description

Mattermost versions 9.5.x <= 9.5.3, 9.7.x <= 9.7.1 and 8.1.x <= 8.1.12 fail to perform a proper authorization check in the /api/v4/groups/<group-id>/channels/<channel-id>/link endpoint which allows a user to learn the members of an AD/LDAP group that is linked to a team by adding the group to a channel, even if the user has no access to the team.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.13, 9.5.4, 9.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-34029 or the next vulnerability affects your stack