What’s Vulnerable › Vulnerabilities
CVE-2024-34051
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A Reflected Cross-site scripting (XSS) vulnerability located in htdocs/compta/paiement/card.php of Dolibarr before 19.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into the facid parameter.
Affected products
- Dolibarr: before 19.0.2 — fixed in 19.0.2
How to fix
Upgrade to a fixed version: Dolibarr 19.0.2. Check the vendor advisory for mitigations.
References
- https://blog.smarttecs.com/posts/2024-004-cve-2024-34051/
- https://blog.smarttecs.com/posts/2024-004-cve-2024-34051/
Get alerted when CVE-2024-34051 or the next vulnerability affects your stack