What’s Vulnerable › Vulnerabilities
CVE-2024-34065: @strapi/plugin-users-permissions leaks 3rd party authentication tokens and authentication bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-12 · updated 2026-06-17
- Weakness: CWE-294
Description
Strapi is an open-source content management system. By combining two vulnerabilities (an `Open Redirect` and `session token sent as URL query parameter`) in @strapi/plugin-users-permissions before version 4.24.2, is its possible of an unauthenticated attacker to bypass authentication mechanisms and retrieve the 3rd party tokens. The attack requires user interaction (one click). Unauthenticated attackers can leverage two vulnerabilities to obtain an 3rd party token and the bypass authentication of Strapi apps. Users should upgrade @strapi/plugin-users-permissions to version 4.24.2 to receive a patch.
Affected products
- strapi: before 4.24.2 — fixed in 4.24.2
How to fix
Upgrade to a fixed version: strapi 4.24.2. Check the vendor advisory for mitigations.
References
- https://github.com/strapi/strapi/security/advisories/GHSA-wrvh-rcmr-9qfc
- https://github.com/strapi/strapi/security/advisories/GHSA-wrvh-rcmr-9qfc
Get alerted when CVE-2024-34065 or the next vulnerability affects your stack