What’s Vulnerable › Vulnerabilities
CVE-2024-34072: Deserialization of Untrusted Data in sagemaker-python-sdk
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-502
Description
sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. The sagemaker.base_deserializers.NumpyDeserializer module before v2.218.0 allows potentially unsafe deserialization when untrusted data is passed as pickled object arrays. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. Users are advised to upgrade to version 2.218.0. Users unable to upgrade should not pass pickled numpy object arrays which originated from an untrusted source, or that could have been tampered with. Only pass pickled numpy object arrays from trusted sources.
Affected products
- AWS Sagemaker-Python-Sdk: before 2.218.0 — fixed in 2.218.0
How to fix
Upgrade to a fixed version: AWS Sagemaker-Python-Sdk 2.218.0. Check the vendor advisory for mitigations.
References
- https://github.com/aws/sagemaker-python-sdk/pull/4557
- https://github.com/aws/sagemaker-python-sdk/security/advisories/GHSA-wjvx-jhpj-r54r
- https://github.com/aws/sagemaker-python-sdk/pull/4557
- https://github.com/aws/sagemaker-python-sdk/security/advisories/GHSA-wjvx-jhpj-r54r
Get alerted when CVE-2024-34072 or the next vulnerability affects your stack