What’s Vulnerable › Vulnerabilities
CVE-2024-34096: ZDI-CAN-23472: Adobe Acrobat Reader DC Annotation Use-After-Free Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-416
Description
Acrobat Reader versions 20.005.30574, 24.002.20736 and earlier are affected by a Use After Free vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30002 before 20.005.30635; from 20.001.30002 before 20.005.30636 — fixed in 20.005.30635, 20.005.30636
- Adobe Acrobat DC: from 15.007.20033 before 24.002.20759 — fixed in 24.002.20759
- Adobe Acrobat Reader: from 20.001.30002 before 20.005.30635; from 20.001.30002 before 20.005.30636 — fixed in 20.005.30635, 20.005.30636
- Adobe Acrobat Reader: from 15.007.20033 before 24.002.20759 — fixed in 24.002.20759
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30635, 20.005.30636; Adobe Acrobat DC 24.002.20759; Adobe Acrobat Reader 20.005.30635, 20.005.30636; Adobe Acrobat Reader 24.002.20759. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb24-29.html
- https://helpx.adobe.com/security/products/acrobat/apsb24-29.html
Get alerted when CVE-2024-34096 or the next vulnerability affects your stack