What’s Vulnerable › Vulnerabilities
CVE-2024-34101: ZDI-CAN-23614: Adobe Acrobat Reader DC PDF File Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-125
Description
Acrobat Reader versions 20.005.30574, 24.002.20736 and earlier Answer: are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30002 before 20.005.30635; from 20.001.30002 before 20.005.30636 — fixed in 20.005.30635, 20.005.30636
- Adobe Acrobat DC: from 15.007.20033 before 24.002.20759 — fixed in 24.002.20759
- Adobe Acrobat Reader: from 20.001.30002 before 20.005.30635; from 20.001.30002 before 20.005.30636 — fixed in 20.005.30635, 20.005.30636
- Adobe Acrobat Reader: from 15.007.20033 before 24.002.20759 — fixed in 24.002.20759
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30635, 20.005.30636; Adobe Acrobat DC 24.002.20759; Adobe Acrobat Reader 20.005.30635, 20.005.30636; Adobe Acrobat Reader 24.002.20759. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb24-29.html
- https://helpx.adobe.com/security/products/acrobat/apsb24-29.html
Get alerted when CVE-2024-34101 or the next vulnerability affects your stack