What’s Vulnerable › Vulnerabilities

CVE-2024-34118: Adobe illustrator 2024 TIF File parsing Division by zero denial of service

Description

Illustrator versions 28.5, 27.9.4 and earlier are affected by an Improper Input Validation vulnerability that could lead to an application denial-of-service condition. An attacker could exploit this vulnerability to render the application unresponsive or terminate its execution. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Illustrator 27.9.5, 28.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-34118 or the next vulnerability affects your stack