What’s Vulnerable › Vulnerabilities
CVE-2024-34121: Illustrator | Integer Overflow or Wraparound (CWE-190)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-190
Description
Illustrator versions 28.6, 27.9.5 and earlier are affected by an Integer Overflow or Wraparound vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 27.0.0 before 27.9.6; from 28.0 before 28.7.1 — fixed in 27.9.6, 28.7.1
How to fix
Upgrade to a fixed version: Adobe Illustrator 27.9.6, 28.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34121 or the next vulnerability affects your stack