What’s Vulnerable › Vulnerabilities
CVE-2024-34134: Illustrator | Out-of-bounds Read (CWE-125)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-14 · updated 2026-06-17
- Weakness: CWE-125
Description
Illustrator versions 28.5, 27.9.4 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 27.0.0 before 27.9.5; from 28.0 before 28.6 — fixed in 27.9.5, 28.6
How to fix
Upgrade to a fixed version: Adobe Illustrator 27.9.5, 28.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34134 or the next vulnerability affects your stack