What’s Vulnerable › Vulnerabilities
CVE-2024-34312
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Virtual Programming Lab for Moodle up to v4.2.3 was discovered to contain a cross-site scripting (XSS) vulnerability via the component vplide.js.
Affected products
- Moodle Virtual Programming Lab: before 4.2.3 — fixed in 4.2.3
How to fix
Upgrade to a fixed version: Moodle Virtual Programming Lab 4.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-34312 or the next vulnerability affects your stack