What’s Vulnerable › Vulnerabilities
CVE-2024-34340: Authentication Bypass when using using older password hashes
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-287
Description
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===`. It is a type juggling vulnerability. Version 1.2.27 contains a patch for the issue.
Affected products
- cacti: before 1.2.27 — fixed in 1.2.27
- Fedoraproject Fedora: 39
How to fix
Upgrade to a fixed version: cacti 1.2.27. Check the vendor advisory for mitigations.
References
- https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
- https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m
- https://lists.debian.org/debian-lts-announce/2024/09/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/
Get alerted when CVE-2024-34340 or the next vulnerability affects your stack