What’s Vulnerable › Vulnerabilities
CVE-2024-34341: The Trix Editor Contains an Arbitrary Code Execution Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.
Affected products
- basecamp trix: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: basecamp trix 2.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/basecamp/trix/commit/1a5c68a14d48421fc368e30026f4a7918028b7ad
- https://github.com/basecamp/trix/commit/841ff19b53f349915100bca8fcb488214ff93554
- https://github.com/basecamp/trix/pull/1147
- https://github.com/basecamp/trix/pull/1149
- https://github.com/basecamp/trix/releases/tag/v2.1.1
- https://github.com/basecamp/trix/security/advisories/GHSA-qjqp-xr96-cj99
- https://github.com/basecamp/trix/commit/1a5c68a14d48421fc368e30026f4a7918028b7ad
- https://github.com/basecamp/trix/commit/841ff19b53f349915100bca8fcb488214ff93554
- https://github.com/basecamp/trix/pull/1147
- https://github.com/basecamp/trix/pull/1149
- https://github.com/basecamp/trix/releases/tag/v2.1.1
- https://github.com/basecamp/trix/security/advisories/GHSA-qjqp-xr96-cj99
Get alerted when CVE-2024-34341 or the next vulnerability affects your stack