What’s Vulnerable › Vulnerabilities
CVE-2024-3435: Path Traversal in parisneo/lollms-webui
- Severity: high (CVSS 8.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-29
Description
A path traversal vulnerability exists in the 'save_settings' endpoint of the parisneo/lollms-webui application, affecting versions up to the latest release before 9.5. The vulnerability arises due to insufficient sanitization of the 'config' parameter in the 'apply_settings' function, allowing an attacker to manipulate the application's configuration by sending specially crafted JSON payloads. This could lead to remote code execution (RCE) by bypassing existing patches designed to mitigate such vulnerabilities.
Affected products
- ParisNeo lollms-webui: before 9.5 — fixed in 9.5
How to fix
Upgrade to a fixed version: ParisNeo lollms-webui 9.5. Check the vendor advisory for mitigations.
References
- https://github.com/parisneo/lollms-webui/commit/bb99b59e710d00c4f2598faa5e183fa30fbd3bc2
- https://huntr.com/bounties/494f349a-8650-4d30-a0bd-4742fda44ce5
- https://github.com/parisneo/lollms-webui/commit/bb99b59e710d00c4f2598faa5e183fa30fbd3bc2
- https://huntr.com/bounties/494f349a-8650-4d30-a0bd-4742fda44ce5
Get alerted when CVE-2024-3435 or the next vulnerability affects your stack