What’s Vulnerable › Vulnerabilities
CVE-2024-34350: Next.js Vulnerable to HTTP Request Smuggling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-444
Description
Next.js is a React framework that can provide building blocks to create web applications. Prior to 13.5.1, an inconsistent interpretation of a crafted HTTP request meant that requests are treated as both a single request, and two separate requests by Next.js, leading to desynchronized responses. This led to a response queue poisoning vulnerability in the affected Next.js versions. For a request to be exploitable, the affected route also had to be making use of the [rewrites](https://nextjs.org/docs/app/api-reference/next-config-js/rewrites) feature in Next.js. The vulnerability is resolved in Next.js `13.5.1` and newer.
Affected products
- Next.js: from 13.4.0 before 13.5.1 — fixed in 13.5.1
- Npm Next: from 13.4.0 before 13.5.1 — fixed in 13.5.1
How to fix
Upgrade to a fixed version: Next.js 13.5.1; Npm Next 13.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-77r5-gw3j-2mpf
- https://github.com/vercel/next.js/security/advisories/GHSA-77r5-gw3j-2mpf
Get alerted when CVE-2024-34350 or the next vulnerability affects your stack