What’s Vulnerable › Vulnerabilities
CVE-2024-34351: Next.js Server-Side Request Forgery in Server Actions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-918
Description
Next.js is a React framework that can provide building blocks to create web applications. A Server-Side Request Forgery (SSRF) vulnerability was identified in Next.js Server Actions. If the `Host` header is modified, and the below conditions are also met, an attacker may be able to make requests that appear to be originating from the Next.js application server itself. The required conditions are 1) Next.js is running in a self-hosted manner; 2) the Next.js application makes use of Server Actions; and 3) the Server Action performs a redirect to a relative path which starts with a `/`. This vulnerability was fixed in Next.js `14.1.1`.
Affected products
- Next.js: from 13.4.0 before 14.1.1 — fixed in 14.1.1
- Npm Next: from 13.4.0 before 14.1.1 — fixed in 14.1.1
How to fix
Upgrade to a fixed version: Next.js 14.1.1; Npm Next 14.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/8f7a6ca7d21a97bc9f7a1bbe10427b5ad74b9085
- https://github.com/vercel/next.js/pull/62561
- https://github.com/vercel/next.js/security/advisories/GHSA-fr5h-rqp8-mj6g
- https://github.com/vercel/next.js/commit/8f7a6ca7d21a97bc9f7a1bbe10427b5ad74b9085
- https://github.com/vercel/next.js/pull/62561
- https://github.com/vercel/next.js/security/advisories/GHSA-fr5h-rqp8-mj6g
Get alerted when CVE-2024-34351 or the next vulnerability affects your stack