What’s Vulnerable › Vulnerabilities
CVE-2024-34355: TYPO3 vulnerable to an HTML Injection in the History Module
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
TYPO3 is an enterprise content management system. Starting in version 13.0.0 and prior to version 13.1.1, the history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account. TYPO3 version 13.1.1 fixes the problem described.
Affected products
- typo3: from 13.0.0 before 13.1.1 — fixed in 13.1.1
How to fix
Upgrade to a fixed version: typo3 13.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/commit/56afa304ba8b5ad302e15df5def71bcc8d820375
- https://github.com/TYPO3/typo3/security/advisories/GHSA-xjwx-78x7-q6jc
- https://typo3.org/security/advisory/typo3-core-sa-2024-007
- https://github.com/TYPO3/typo3/commit/56afa304ba8b5ad302e15df5def71bcc8d820375
- https://github.com/TYPO3/typo3/security/advisories/GHSA-xjwx-78x7-q6jc
- https://typo3.org/security/advisory/typo3-core-sa-2024-007
Get alerted when CVE-2024-34355 or the next vulnerability affects your stack