What’s Vulnerable › Vulnerabilities
CVE-2024-34362: Envoy affected by a crash (use-after-free) in EnvoyQuicServerStream
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-416
Description
Envoy is a cloud-native, open source edge and service proxy. There is a use-after-free in `HttpConnectionManager` (HCM) with `EnvoyQuicServerStream` that can crash Envoy. An attacker can exploit this vulnerability by sending a request without `FIN`, then a `RESET_STREAM` frame, and then after receiving the response, closing the connection.
Affected products
- envoyproxy envoy: before 1.27.6; from 1.28.0 before 1.28.4; from 1.29.0 before 1.29.5; from 1.30.0 before 1.30.2 — fixed in 1.27.6, 1.28.4, 1.29.5, 1.30.2
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.27.6, 1.28.4, 1.29.5, 1.30.2. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-hww5-43gv-35jv
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-hww5-43gv-35jv
Get alerted when CVE-2024-34362 or the next vulnerability affects your stack