What’s Vulnerable › Vulnerabilities
CVE-2024-34391: libxmljs attrs type confusion RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-843
Description
libxmljs is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking a function on the result of attrs() that was called on a parsed node. This vulnerability might lead to denial of service (on both 32-bit systems and 64-bit systems), data leak, infinite loop and remote code execution (on 32-bit systems with the XML_PARSE_HUGE flag enabled).
Affected products
- libxmljs: before 1.0.11 — fixed in 1.0.11
How to fix
Upgrade to a fixed version: libxmljs 1.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/libxmljs/libxmljs/issues/645
- https://research.jfrog.com/vulnerabilities/libxmljs-attrs-type-confusion-rce-jfsa-2024-001033988/
- https://github.com/libxmljs/libxmljs/issues/645
- https://research.jfrog.com/vulnerabilities/libxmljs-attrs-type-confusion-rce-jfsa-2024-001033988/
Get alerted when CVE-2024-34391 or the next vulnerability affects your stack