What’s Vulnerable › Vulnerabilities
CVE-2024-34392: libxmljs namespaces type confusion RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-843
Description
libxmljs is vulnerable to a type confusion vulnerability when parsing a specially crafted XML while invoking the namespaces() function (which invokes _wrap__xmlNode_nsDef_get()) on a grand-child of a node that refers to an entity. This vulnerability can lead to denial of service and remote code execution.
Affected products
- libxmljs: before 1.0.11 — fixed in 1.0.11
How to fix
Upgrade to a fixed version: libxmljs 1.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/libxmljs/libxmljs/issues/646
- https://research.jfrog.com/vulnerabilities/libxmljs-namespaces-type-confusion-rce-jfsa-2024-001034096/
- https://github.com/libxmljs/libxmljs/issues/646
- https://research.jfrog.com/vulnerabilities/libxmljs-namespaces-type-confusion-rce-jfsa-2024-001034096/
Get alerted when CVE-2024-34392 or the next vulnerability affects your stack